如何修改或更新WordPress的PHP版本(Cloudways)

PHP的版本對WordPress極其重要,可說是WordPress的核心,因為你網站所呈現的主題跟後台使用的插件都是PHP寫的。來這邊手把手教你如何修改或更新WordPress的PHP版本。 為何需要更新網站的PHP版本? 您的網站將更快,因為最新版本的PHP更有效。更新到最新的受支持版本(當前為7.4)可以極大地提高性能。對於較舊的版本,速度提高了3到4倍。 您的網站將更加安全。與WordPress一樣,PHP由其社區維護。由於PHP非常流行,因此它是黑客的目標-但最新版本將具有最新的安全功能。較舊的PHP版本沒有此功能,因此更新對於確保WordPress網站的安全至關重要。 然後有許多次要好處: 更快的WordPress網站將受到搜索引擎的獎勵,因此您在搜索中的排名會更高! 速度更快的網站可以更好地吸引訪問者(如果加載時間太長,他們就會離開),從而使您的網站更有效。 一個更安全的網站可以更好地保護其免受黑客攻擊,以及與被黑客入侵的網站相關的成本和聲譽損失。 更新前的作業 WordPress本身可以使用PHP版本早於5.6.20(我們目前建議使用7.4版本,因此具有很好的向後兼容性!),但是我們不知道您的主題或插件是否可以工作。 在繼續更新之前,您應該確認以下: 對您的網站進行備份:如果出現任何問題,備份將使您將網站恢復為現在的狀態。有很多免費的備份插件可用,因此,如果您還沒有備份解決方案,請使用其中之一。為了還原此備份,您還需要Web主機將PHP版本移回當前版本(稍後將介紹如何執行此操作)。 更新WordPress,主題和插件:從WordPress儀表板,轉到“更新”,然後全部更新。無論如何,您應該定期執行此操作。完成後,檢查您的網站是否按預期工作。 檢查PHP兼容性:安裝PHP兼容性檢查器插件以檢查主題和插件是否存在問題。該插件不是完美的,可能會丟失項目或標記誤報,但在大多數情況下確實可以使用。 解決任何PHP兼容性問題:如果PHP兼容性檢查器插件發現任何問題,請與主題或插件開發人員聯繫並要求他們進行調查。如果他們不能或不會回复您,請在WordPress.org上查找具有類似功能的主題或插件,並改用其中一種。 如何修改或更新WordPress的PHP版本? 因為我的網站是透過Cloudways 進行Host,所以接下來的內容要是透過Cloudways服務進行設定。 01.起初在WP後台會跟你提示你需要更新你的PHP版本後才能更新你的插件。 02.進入伺服器設定頁面後,點選Settings & Packages,然後點選Packages 03.點選PHP版本進行更改,我目前更新到PHP7.4。 04.點選後他會問你是否已經有備份了,確認有備份點選OK。 05.此時伺服器進行更新作業,約等到5-10分鐘即可。 06. 更新完畢的畫面。 07.更新完來到WP的後台,安裝官方建議的相容性檢查插件。 08.選擇要確認相容性的PHP版本,以及詢問是否只檢查目前的插件以及樣式或是全部檢查。 09. 檢查需要花費10分鐘左右,插件會顯示測試結果,結果如下: